Hogyan javíts „NPM HIBA! Váratlanul vége JSON input feldolgozása közben” a Vue CLI telepítő

szavazat
11

Szeretnék telepíteni Vue CLI. és futok ezt én Git Bash.

[email protected] MINGW64 ~
$ npm install -g @vue/cli

de mivel a hiba, mint ez:

[email protected] MINGW64 ~
$ npm install -g @vue/cli
npm ERR! Unexpected end of JSON input while parsing near '...ery:latest,throug'

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ECLIPSE\AppData\Roaming\npm-cache\_logs\2019-10-09T02_48_52_427Z-debug.log

Igyekszem a megoldás StackOverflow ez a téma itt

. megpróbálom a

[email protected] MINGW64 ~/Desktop
$ npm cache clean --force
npm WARN using --force I sure hope you know what you are doing.

de megpróbálom telepíteni újra, annak van ugyanaz a hiba. valaki tud segítsen nekem erről?

A kérdést 09/10/2019 04:57
felhasználó
Más nyelveken...                            


2 válasz

szavazat
0

Lehet használni

npm uninstall -g vue-cli
npm cache clean
npm install -g v[email protected]

Ha a fenti nem működik, akkor lehet próbálni ezt a (az https://docs.npmjs.com/cli/audit )

npm audit fix

hogy átvizsgálja a projekt réseket, és automatikusan telepíti bármely kompatibilis frissítésekről veszélyeztetett függőségek

Válaszolt 09/10/2019 07:25
a forrás felhasználó

szavazat
0

Volt egy nagyon hasonló probléma és egyszerű npm cache clean --forceparancs nem segíthet. A probléma megoldása a törlését a C: \ Users \ Felhasználó \ AppData \ Roaming \ NPM és a C: \ Users \ Felhasználó \ AppData \ Roaming \ NPM-cache könyvtárak és fut egy npm cache clean --forceparancs után. Ezután npm installműködött megfelelően. Ha a probléma továbbra is megjelenik, telepítse újra node.js és NPM. Ne felejtsük el, hogy ha az összes korábbi fájlok a hozzájuk kapcsolódó hagyni a telepítés előtt!

Válaszolt 06/01/2020 14:02
a forrás felhasználó

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more